Upgrade Safari??

Discussion of general issues, not related to a specific Mac or iDevice operating system.
Post Reply
KarenColes
Forum Member - Level 3
Forum Member - Level 3
Posts: 130
Joined: Thu Jun 09, 2011 1:56 pm

Upgrade Safari??

Post by KarenColes » Tue Jul 07, 2015 2:38 pm

My friend has my old 3GB MacBook Pro (circa 2008) running OS 10.5.8. It has Safari 5.0.6 which will no longer function well on a variety of sites. Can Safari be upgraded on this Mac? I've checked Apple.com/safari, and I don't seem able to download a newer version. It may be time for her to replace this laptop, since upgrading the OS may not be viable without upgrading the ram. Thoughts?

User avatar
Bob Wiswell
Forum Member - Level 3
Forum Member - Level 3
Posts: 247
Joined: Thu Apr 07, 2011 4:38 pm

Re: Upgrade Safari??

Post by Bob Wiswell » Tue Jul 07, 2015 4:08 pm

Probably you will only be able to upgrade to OSX 10.6.8, Snow Leopard. I am on an old laptop running Snow Leopard and Safari 5.1.10 and this is the highest OSX (and Safari) that I can use, according to Apple. I get messages from websites saying that I am using an old version of Internet Explorer (I assume that they cannot detect that it is Safari), and that I should upgrade to enjoy the latest features of their website. However, I have never not been able to accomplish what I want to do at the website.

I have heard that Firefox has a browser that some sites like better, but I have not tried it. I just ignore their comment and go on with my business.

User avatar
Richard Serkes
Forum Member - Level 5
Forum Member - Level 5
Posts: 1027
Joined: Thu Mar 31, 2011 9:21 pm
Location: Port Angeles, WA

Re: Upgrade Safari??

Post by Richard Serkes » Wed Jul 08, 2015 8:08 am

As good as Safari is, there are alternatives that aren't tied to specific Mac OS versions. Check out Chrome and Firefox.
---
Always burn your bridges. You never know who's coming up from behind.

User avatar
Stephen Hart
Forum Member - Level 5
Forum Member - Level 5
Posts: 3139
Joined: Thu Apr 07, 2011 10:09 am

Re: Upgrade Safari??

Post by Stephen Hart » Wed Jul 08, 2015 10:27 am

Richard Serkes wrote:As good as Safari is, there are alternatives that aren't tied to specific Mac OS versions. Check out Chrome and Firefox.
We've always kept Firefox around and updated because there are occasional sites that require it.

Chrome, however, I'd avoid for a while. Apparently the underlying technology, Chromium, installs a microphone listening system without notice. Ostensibly this is so you have voice control of Chrome/Chromium. Macintouch has some comments on that issue.
"Design is not just what it looks like and feels like. Design is how it works."
Steve Jobs

KarenColes
Forum Member - Level 3
Forum Member - Level 3
Posts: 130
Joined: Thu Jun 09, 2011 1:56 pm

Re: Upgrade Safari??

Post by KarenColes » Wed Jul 08, 2015 10:51 am

Maybe we'll give Firefox a try if there won't be a problem using it on such old system software.

KarenColes
Forum Member - Level 3
Forum Member - Level 3
Posts: 130
Joined: Thu Jun 09, 2011 1:56 pm

Re: Upgrade Safari??

Post by KarenColes » Thu Jul 09, 2015 10:13 pm

Apparently Firefox is not the solution. I downloaded it, but when I tried to launch it, I got the message "This version of Firefox cannot be used with this version of Mac OSX."I guess I could try an older version of Firefox if I knew how to find one. Safari can barely open the Firefox website. It looks like what I'm reading there, and many other websites, is HTML code.

KarenColes
Forum Member - Level 3
Forum Member - Level 3
Posts: 130
Joined: Thu Jun 09, 2011 1:56 pm

Re: Upgrade Safari??

Post by KarenColes » Thu Jul 09, 2015 11:28 pm

I figured out how to find an older Firefox version, and downloaded version 38.0.5. Unfortunately, I got the same message when I tried to open it ".... cannot be used with this version of Mac OSX."

Thoughts?

User avatar
Richard Serkes
Forum Member - Level 5
Forum Member - Level 5
Posts: 1027
Joined: Thu Mar 31, 2011 9:21 pm
Location: Port Angeles, WA

Re: Upgrade Safari??

Post by Richard Serkes » Fri Jul 10, 2015 6:08 am

To use Firefox on your Mac you'll have to use Firefox v16.x. Here's a link that will explain it to you as well as offer a link to this old version of Firefox.


https://support.mozilla.org/en-US/kb/fi ... -os-x-10-5
---
Always burn your bridges. You never know who's coming up from behind.

KarenColes
Forum Member - Level 3
Forum Member - Level 3
Posts: 130
Joined: Thu Jun 09, 2011 1:56 pm

Re: Upgrade Safari??

Post by KarenColes » Fri Jul 10, 2015 10:17 am

Thanks so much, Richard. So far, v15.x seems to work. Lots of messages about its not being supported and not being able to access everything, but that's to be expected. For the time being, it may enable my friend (whose computer usage is minimal) to avoid having to buy a new computer for awhile.

8string
Forum Member - Level 1
Forum Member - Level 1
Posts: 23
Joined: Thu Jul 21, 2011 8:41 pm

Re: Upgrade Safari??

Post by 8string » Thu Jul 23, 2015 7:07 am

Biggest problem with all these older versions of browsers, is that they aren't updated for security fixes. If you are just surfing for casual use, it's one thing, but I'd be very cautious about doing any kind of banking online etc. The bad guys know the vulnerabilities by this time, can set the traps at fake copycat web sites, etc, and you are more likely to be unknowingly compromised depending on the site you visit. Not that it happens to everyone, it's just the reality that the developers of these browsers stop caring about them, and no one at Apple, Google or other companies is assigned to work on them anymore.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest