iTunes won't launch automatically...

Discussion of general issues, not related to a specific Mac or iDevice operating system.
Post Reply
User avatar
JerryFreilich
Forum Member - Level 3
Forum Member - Level 3
Posts: 424
Joined: Mon Apr 04, 2011 6:35 pm
Location: Bend, OR

iTunes won't launch automatically...

Post by JerryFreilich » Sun Aug 14, 2011 7:56 pm

OK folks, what do you think about this?

When I plug in my iPhone 4 normally iPhoto launches (if I've taken any photos with the phone) and iTunes launches to begin synchronizing the phone. For the past few weeks, and for no apparent reason, iTunes is no longer launching automatically. I can open iTunes and it immediately "sees" the iPhone and begins synchronizing. But until you launch iTunes manually, it doesn't sync. I had thought I'd track down an answer to this problem but found it was a hard thing to put in a Google search. And then I thought I'd wait until I installed Lion to see if that fixed the problem. In fact Lion has not fixed the problem. iTunes still doesn't launch unless I open it manually. I've gone into my Account Preferences under Login Items and I see that iTunes Helper is installed and should be operating. So I have two questions.... Does anyone know how I might fix this? And failing that, does anyone know how I could search for an answer to this annoyance?

I see that I'm not the only person having this problem, but the solutions posted there have not worked for me.... yet:

https://discussions.apple.com/thread/32 ... 5&tstart=0

User avatar
JerryFreilich
Forum Member - Level 3
Forum Member - Level 3
Posts: 424
Joined: Mon Apr 04, 2011 6:35 pm
Location: Bend, OR

Re: iTunes won't launch automatically...

Post by JerryFreilich » Sun Aug 14, 2011 8:13 pm

Following one person's tips on the Apple.com forum, I tried looking at my iTunes prefs and found to my astonishment 237 prefs files in there that looked like this:
Attachments
iTunesPrefs.jpg
iTunesPrefs.jpg (149.69 KiB) Viewed 1086 times

User avatar
Stephen Hart
Forum Member - Level 5
Forum Member - Level 5
Posts: 3045
Joined: Thu Apr 07, 2011 10:09 am

Re: iTunes won't launch automatically...

Post by Stephen Hart » Mon Aug 15, 2011 6:47 am

I hadn't noticed, but just now checked and found the same problem.
Following the instructions in the Apple Discussion you cited fixed the problem for me. Apparently iTunes 4 doesn't automatically set up iTunes Helper.app as a Login Item.

Note that you not only need to set it up as a login item, but it also has to be running. So either double click it in the Finder so it's running (no icon will appear in the Dock), or restart after you've made sure it's listed as a Login Item.

I also see lots of iTunes.plist files.

Copied and edited slightly from the Apple Discussion:
iTunes Helper must be running to start iTunes when you plug in your iPhone/iPod.

Navigate to hard drive/Applications folder
Control Click on iTunes.app and select Show Package Contents
Navigate to Contents/MacOS/
Double-click on iTunes Helper.app to get it running, or complete the steps below and restart the Mac
Open System Preferences and go to Users & Groups
Select Login Items
Drag iTunes Helper.app from the Finder into the Login Items list or click + and navigate to iTunes Helper.app
"Design is not just what it looks like and feels like. Design is how it works."
Steve Jobs

User avatar
JerryFreilich
Forum Member - Level 3
Forum Member - Level 3
Posts: 424
Joined: Mon Apr 04, 2011 6:35 pm
Location: Bend, OR

Re: iTunes won't launch automatically...

Post by JerryFreilich » Wed Aug 17, 2011 5:44 pm

By doing this twice, I have now apparently solved the problem and it's working correctly again. Very bizarre why the first time didn't fix it??

User avatar
Stephen Hart
Forum Member - Level 5
Forum Member - Level 5
Posts: 3045
Joined: Thu Apr 07, 2011 10:09 am

Re: iTunes won't launch automatically...

Post by Stephen Hart » Wed Aug 17, 2011 6:43 pm

JerryFreilich wrote:By doing this twice, I have now apparently solved the problem and it's working correctly again. Very bizarre why the first time didn't fix it??
Gremlinz?
"Design is not just what it looks like and feels like. Design is how it works."
Steve Jobs

User avatar
JerryFreilich
Forum Member - Level 3
Forum Member - Level 3
Posts: 424
Joined: Mon Apr 04, 2011 6:35 pm
Location: Bend, OR

Re: iTunes won't launch automatically...

Post by JerryFreilich » Fri Aug 19, 2011 9:04 pm

I have, for lack of any further information, left all those plist files in the prefs folder where I found them. I have no earthly clue why they're all there.. and they seem like they're probably unnecessary, but ?????? I suppose I could delete them all and see if it makes any difference.

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests