Page 1 of 2

Finder has pinwheel of death

Posted: Sun Dec 31, 2017 9:11 am
by jest2dogs
Recently did two "major" things on my 2015 13" MBP:

1) updated to the latest OS this month.

And then, more recently,

2) I changed my Apple ID. Doing that alone created all kinds of headaches with my three devices (MBP, 4th gen iPad and iPhone 5s). I hadn't been using iCloud but suddenly found all matter of pop ups related to it. And a warning that I had used up half my allotment! (I discovered all my iPad Photos had been moved to the Cloud along with other stuff.)

I think I straightened out the iCloud problem by going into iCloud in each device and making sure all apps except "Find My..." and "Calendar" were "Off". (I was amazed to find most all of them "On" on the iPad! How'd that happen?)

BTW, I have an external hard drive that contains the "Photo" app and all my photos. Should I be disconnecting that before I do a "Shutdown"? I ask, because when attached, it normally flashes slowly. This morning, in the pale light of dawn, with the computer still "On" but the lid closed (which is how I usually leave it at night) the white light on the hard drive was flashing rapidly.

I opened the computer lid and clicked on the "Finder" icon (which was noted as already open with a dot beside the icon in the "Dock"). But "Finder" did not pop to the forefront. This has happened before. I had to minimize all the windows of open programs (about four) and finally found "Finder". When I moved the cursor over it to check on the external hard drive...

...the PINWHEEL OF DEATH (POD) appeared.

This has happened now since the second of the aforementioned major actions. (BTW, I do not really like all the changes to the Photo app in the new OS).

I cannot "Force Quit" the "Finder" because the "POD" precludes it and I am forced to manually shut down the computer by holding down the power button. I think I am able to use the cursor to choose "Shutdown" when the pop up window appears but I can't recall right now. I seem to recall that one time this happened the "POD" precluded that choice as well.

I, obviously have been unable to properly "Eject" the Photo hard drive as a precaution before shutdown and have simply left it connected, as I have with my regular, back up hard drive. To my knowledge, my photos are still intact.

So, what's causing the "POD" on the "Finder"?

Re: Finder has pinwheel of death

Posted: Sun Dec 31, 2017 10:51 am
by Stephen Hart
Hard to tell what the problem is, but it sounds like the external drive isn't mounting properly, or isn't accessible to the Finder.
If it's making any kind of unusual noise, switch it off and don't turn it back on right away.

If it's not making any unusual noise, shut down the Mac, then switch off the external drive.
Now start the Mac. If everything's OK, then first unplug and replug the cable to the external drive and then switch on the external drive.
If it starts up, then I'd start by using Disk (standard on all Macs) to check the disk. If that checks out OK, but problems persist, you'll need more powerful tools.
If the drive starts up and Disk Utility can't see it, or shows it but can't do anything with it, or tries and reports errors, you may need some expert hands-on help to attempt to recover the drive. Sometimes external drives go bad because of the power supply, while the drive inside is OK.

Re: Finder has pinwheel of death

Posted: Sun Dec 31, 2017 11:57 pm
by Ray Bentsen
Several thoughts occurred to me when reading the original post:

1. Exactly how did you change your Apple ID, and why? Since an Apple ID is used to keep track of all synced data, including iTunes, iBooks, and App Store purchases (both Mac and iOS), not to mention syncing the iCloud Photo Library ... I can imagine all kinds of problems. I would not suggest that anyone ever attempt to change their Apple ID. (The password YES, but the Apple ID itself NO)

2. I was always of the opinion that Mac apps should stay in the Applications Folder so that associated support files could be found. I can understand why you might want to have a Photos (or iPhoto) library on an external drive, but don't know why the app need be put on an external drive. I have never tried doing that, so don't know for sure what problems it might cause ... if any. Possibly others could comment on the advisability of moving apps out of the Applications Folder and to an external drive.

3. Anyway, if my Finder were persistently showing the POD, I wouldn't really be concerned with why it was happening (since it could just be some sort of corruption), but would just rebuild the operating system by downloading and running a new Installer from the App Store ... and see if that fixes the problem. Again, possibly others might comment on if/when doing that is advisable.


Re: Finder has pinwheel of death

Posted: Mon Jan 01, 2018 2:33 pm
by jest2dogs
Thank you both Stephen and Ray for responding.

Stephen, I disconnected the 2 Tb, external (portable) hard drive as you suggested. It has been plugged into a 4-outlet, "Shark" USB 3.0 Hub along with my 1Tb, back-up (portable) hard drive. When I reconnected it I used one of two dedicated USB ports on my 2015 MBP.

I should mention that the POD (Pinwheel of Death) usually appears when I desire to use Finder for something like ejecting a device or accessing some app., only to find I can't do anything with it, not even access the APPLE icon to choose "Force Quit". So I press the on/off button and I then get a window that asked if I'd like to shutdown and it is then that I can use the cursor. (Note: with POD present I can still access other programs, just not the "Finder".

I have had success shutting down the computer and restarting. Once all is up and running I make sure to close the Finder and everything works fine until the next time. I wonder if leaving Finder "open" is allowing some odd quirks? I will make sure to close it after every use.

I have noted some other oddities using the cursor. The other day while perusing "Pinterest" I clicked on a picture and it opened the one next to it. And this was happening with all the Pinterest choices. So I closed Pinterest, re-started the computer and all was well. This morning, I had a similar problem with an email from the Washington Post. The email lists the daily big stories and one can click on a link and it takes you to Safari for the full story. Today (it only did this once) I clicked on the link and it took me to a different story, much like the Pinterest issue a few days earlier. (I closed the safari page, returned to the email and re-tried the link successfully.) I do not know if the the two oddities are linked or happenstance.

As I type this response I am getting yet another oddity, the page is "jumping" intermittently with either a keystroke or a return key. Yep, its the return key.
It might be just adding lines but sometimes it adds a line and sometimes it moves the entire page up. Haven't noted this hyper-ness before. Maybe I am just being hyper-vigilant? After all, last night was New Years Eve and there were libations.

Ray, I misspoke. The Photos Library and all my photos and videos are on the external drive. The "app" with it's icon is still visible in the Finder under Applications in the laptop. When "clicked on", with the hard drive disconnected, a pop-up appears saying it can't connect to the Library which was last known to be on (named) external hard drive. (Pretty amazing information grab.) Glenn at Mac Traders set this hard drive up for me as I felt it was a little over my head, ATT, as I have deep fears about losing my photo library. (BTW, the photos and library were moved because the 15,000+ items were taking up too much of my 250Gb internal drive. The arrangement seems to work fine to date and leaves plenty of space on the internal drive for other stuff.)

I still don't know what causes Finder to lock up with the "POD". As I noted, I have to actually minimize or close other programs in order to find the open Finder on the screen. It does not pop to the forefront when the Dock icon is clicked (it has the DOT next to the icon letting me know it's "on screen" already...somewhere).

I had no problem last night getting to Finder and ejecting the external (photo) hard drive. Does that mean the problem is solved or just diverted?

I appreciate everyone's learned insights. Thanks.


Re: Finder has pinwheel of death

Posted: Mon Jan 01, 2018 3:07 pm
by Stephen Hart
I wonder if leaving Finder "open" is allowing some odd quirks? I will make sure to close it after every use.
Leaving a Finder window open should have no effect. It is possible to force quit the Finder, but it will immediately reopen. Maybe leaving a dozen Finder windows open is a bad idea.

Ah, an external USB hub. That's worth checking out. I have one from OWC--normally a really reliable company--and have had to replace it twice. Check to see if the external works reliably when plugged into each USB port you have. A single port can go bad either on the hub or on the Mac. You might have to leave it connected in each USB port for a day or so to really check.

Your other issues are ringing a bell. I once had a heck of a time with things jumping around and my mouse not selecting what I thought I was aiming at. Turns out my cat was resting a paw on a key of my keyboard. :D If that's not your problem, it could be a bad key on your keyboard. Try a different keyboard.

The reason the Finder won't come to the front sometimes is because it is frozen. That's why it shows a spinning pie icon. As I wrote before, I suspect the Finder can't access your external drive. If it were the internal drive, you'd have lots of other problems.

Finally, remember that if you keep files only on an external drive, you need to back up that drive.

Re: Finder has pinwheel of death

Posted: Mon Jan 01, 2018 5:22 pm
by jest2dogs
Ray, as for why I changed my Apple ID (and consequently, my password), it was connected to a google email address that I haven't used in several years (I find gmail rather intrusive). I am trying to close that account as much as possible.

Yes, I changed iTunes, all three devices, etc., etc.. The site will also ask for your new info. I also choose not to utilize iCloud except for Calendar and Find My IPhone/Mac/iPad. I just don't feel that comfortable entrusting my library to the cloud. I was dismayed when I found my iPad had somehow allowed stuff to be sent it the cloud. Fortunately, the photos had already been backed up when I selectively severed the tie the other day.

If the problem persists without a solution turning up on the forum, I may, indeed, have to, as you suggest, "re-boot"/"rebuild" everything.

Thanks for your perspective. As long as my photos are secure(*) I am much less anxious about diving in and wrestling with stuff.

*(Several years ago, before I had a Mac, and while recovering from the flu, I "edited" over a year's worth of photo "duplicates". Unfortunately, my fevered mind failed to realize I was deleting the originals. Such a mistake kinda puts the fear of god in ya' when you delete pics of the last Xmas the whole family was together, etc..🙀)

Re: Finder has pinwheel of death

Posted: Mon Jan 01, 2018 7:20 pm
by Ray Bentsen
The reason that I asked about HOW you changed your Apple ID, is that there is a correct process so that things don't get messed up.

The instructions are located here:

Hope all turns out well, whatever steps you took!


Re: Finder has pinwheel of death

Posted: Mon Jan 08, 2018 12:59 pm
by jest2dogs
Okay, then. Here I am again.

I took a photo with my iPhone and Airdropped it to the MBP. I attempted to open Finder... I had to Force Quit it as it was not responding. Once re-opened, I opened the downloaded picture with Photos (my external hard drive with the Library being already attached).

I edited the photo in "Photo" , saved it and reduced it back to the album and then proceeded to drag it into an email I was composing. All I got was an arrow and the "jpg number" of the photo. When I clicked on that icon, a box popped up telling me the photo was not yet downloaded. What?

So I tried an older photo and I got the same results, "Not Downloaded".

So, two things. Why was the Finder "Not responding" and why were the photos not dropping onto the email ("Not yet downloaded" "Do you want to download?" Yes.)??

Is it he Finder or the External Hard Drive (with the Photo Library)? Or both? (BTW, the other day I opened "Disk Utility" and tried a "repair" to the hard drive and I got a message that it could not do that. ("First Aid could not unmount the volume for repair.") I presume that is because the MBP does not have enough room to download it and repair it?

The 2nd floor window is open and ready....LOL
Screen Shot 2018-01-08 at 12.51.39 PM.png
Screen Shot 2018-01-08 at 12.51.39 PM.png (852.65 KiB) Viewed 1902 times
P.S. BTW, dragging a photo into the text did not seem to work.

Re: Finder has pinwheel of death

Posted: Mon Jan 08, 2018 2:15 pm
by Stephen Hart
Two things:
1. Maybe Photos has the image in iCloud and you need to download it to your Mac. But if you AirDropped it to your Mac, that would transfer the actual file, not just a marker for an iCloud image, I think.
I use Aperture, which has an email button. So to email a version of an image I'm looking at in Aperture, the correct workflow is to select the image and click email.
In Photos, the equivalent workflow is to select the image, then click the Share button and select email.

2. You can't repair a volume that's running the OS. You can check it, but for repair, you have to start up with a different startup volume.

Re: Finder has pinwheel of death

Posted: Mon Jan 08, 2018 11:11 pm
by jest2dogs

So to repair it I'd need another computer. Is the about right?

As for "Sharing" I usually select "Add to Photos" or "Other" and then open the photos app in Finder.