Problem With Safari

Discussion of general issues, not related to a specific Mac or iDevice operating system.
Post Reply
User avatar
Richard Serkes
Forum Member - Level 5
Forum Member - Level 5
Posts: 1026
Joined: Thu Mar 31, 2011 9:21 pm
Location: Port Angeles, WA

Problem With Safari

Post by Richard Serkes » Sat Jan 09, 2016 10:00 am

First of all, all software is up-to-date. The Mac Mini is using OS 10.11.2 and Safari is v9.0.2. I even made sure the dreaded Adobe Flash module is as current as possible. And if it means anything, the problem I'm about to describe showed itself before I upgraded the Flash module.

Here's the problem on my wife's Mac Mini. Safari doesn't display any graphics. None. It's all text and the text is scrunched up into to upper left-hand corner. I tried working through all the Preferences but with no success. I rebooted the Mini but that didn't do anything.

Next I switched accounts from hers to mine and Safari worked just fine. This makes me think it's a setting in her Safari Preferences because switching accounts makes the problem go away. In other words, I don't think there are any corrupted Safari files on the Mini otherwise switching accounts wouldn't "fix" things.

Now back into her account, both Firefox and Chrome work just fine. And that's her current work around; she's using Firefox. But I'd really like to know what's going on with Safari in her account only.

Any ideas?
---
Always burn your bridges. You never know who's coming up from behind.

User avatar
rickj
Forum Member - Level 2
Forum Member - Level 2
Posts: 98
Joined: Wed Apr 06, 2011 10:29 pm

Re: Problem With Safari

Post by rickj » Sat Jan 09, 2016 5:12 pm

Deleting prefs files is worth a shot. Make sure you're deleting the prefs in the user Library folder, not the root library. If the user library is hidden, you can get to it by holding down the OPTION key and opening the Go Menu in the Finder. Choose Library. Then look in the Preferences folder.

Besides several prefs files that start with com.apple.safari there is one called SafariCloudHistoryPushAgent.plist. Make sure you quit Safari before deleting the prefs (or better yet, dragging them to the desktop so you can put them back in case it screws something up). Also, restart the Mac after deleting the prefs. OS X tends to cache prefs files, and doesn't always recognize that the have been deleted until after a restart.

The order is important- Quit Safari, delete prefs, restart.
Rick

User avatar
Stephen Hart
Forum Member - Level 5
Forum Member - Level 5
Posts: 3105
Joined: Thu Apr 07, 2011 10:09 am

Re: Problem With Safari

Post by Stephen Hart » Sat Jan 09, 2016 9:52 pm

"Design is not just what it looks like and feels like. Design is how it works."
Steve Jobs

User avatar
Richard Serkes
Forum Member - Level 5
Forum Member - Level 5
Posts: 1026
Joined: Thu Mar 31, 2011 9:21 pm
Location: Port Angeles, WA

Re: Problem With Safari

Post by Richard Serkes » Sat Jan 09, 2016 10:14 pm

Thank you Rick and Stephen. I'll try your suggestions tomorrow.

This evening I was busy watching Chandu The Magician with Bela Lugosi. It was released just a year after Dracula and our friend Bela was trying to annihilate the world with a death ray. What a guy!
Attachments
hqdefault.jpg
hqdefault.jpg (12.17 KiB) Viewed 7196 times
---
Always burn your bridges. You never know who's coming up from behind.

User avatar
Richard Serkes
Forum Member - Level 5
Forum Member - Level 5
Posts: 1026
Joined: Thu Mar 31, 2011 9:21 pm
Location: Port Angeles, WA

Re: Problem With Safari

Post by Richard Serkes » Sun Jan 10, 2016 1:02 pm

Fixed it! I went to Preferences/Advanced to allow DEVELOP to display in the menu bar. Then I opened DEVELOP and noticed that "Disable Styles" was checked. I unchecked "Disable Styles" and all is well. I went to several websites and all are displaying graphics properly.

Now the mystery is how did "Disable Styles" get checked off? This is my wife's Mac Mini and I don't have the DEVELOP menu showing in Safari just so she won't get in there and mess around with it. And it wasn't open when I was doing the trouble shooting...as indicated above, I had to open it.

It will probably remain a mystery but the problem is fixed.

And thanks Rick and Stephen or your input.
---
Always burn your bridges. You never know who's coming up from behind.

User avatar
Stephen Hart
Forum Member - Level 5
Forum Member - Level 5
Posts: 3105
Joined: Thu Apr 07, 2011 10:09 am

Re: Problem With Safari

Post by Stephen Hart » Sun Jan 10, 2016 4:09 pm

There's a way to disable styles in Safari with a keyboard shortcut, but that requires that the Develop Menu be turned on.
"Design is not just what it looks like and feels like. Design is how it works."
Steve Jobs

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests