Page 1 of 1

iTunes doesn't launch when iPhone is plugged in

Posted: Fri Jul 10, 2015 9:09 am
by JerryFreilich
Many users on Apple's boards are reporting that since the recent iTunes 12.2 update that the app no longer launches automatically when an iPhone is plugged in for sync. I had the same problem myself. Other posters tracked down the problem as an issue with iTunesHelper.app, a component of the iTunes "package." One solution seems to be replacing the iTunes 12.2 version of iTunesHelper.app with an older version. Users with TimeMachine or other backups can obtain the needed older version of the helper... but it is not entirely obvious how to get it or how to install it replacing this latest version.

I experimented with this and was able to make it work fine. I agree that the problem seems to be solely with the Helper app. I posted an account of how to do this on Apple's board here:
https://discussions.apple.com/thread/71 ... 5&tstart=0

I would be interested to know if other users have had the issue.... and if there is a simpler fix than what I went through.

Re: iTunes doesn't launch when iPhone is plugged in

Posted: Fri Jul 10, 2015 4:03 pm
by Stephen Hart
I just tested, and indeed if I first quit iTunes, then plug in my iPhone, iTunes doesn't launch.

But then, I never quit iTunes usually, so I can imagine lots of users won't notice this bug off the bat.

If I then launch iTunes, my iPhone shows up. In fact, the current version of iTunes is actually better at keeping my iPhone in the device list.

Re: iTunes doesn't launch when iPhone is plugged in

Posted: Sun Jul 12, 2015 10:21 pm
by Jay Cline
Good, I tire of having to quit the app whenever I plug in my iPhone.