Page 1 of 1

macOS Sierra - System Requirements

Posted: Wed Jun 15, 2016 5:34 pm
by Ray Bentsen
System requirements:
MacBook – Late 2009 and later
iMac – Late 2009 and later
MacBook Air – 2010 and later
MacBook Pro -2010 and later
Mac Mini – 2010 and later
Mac Pro – 2010 and later