Page 1 of 1

Audiobook Position Lost

Posted: Thu Aug 06, 2015 4:02 pm
by Stephen Hart
Anyone experienced this (and, I hope, fixed it):

I'm listening to commercial audiobook, purchased from iTunes Store. an audiobook built with Audiobook Builder, from library CDs.

After more than an hour listening, it seems to always want to start over on my iPhone from the beginning.
I've reset the time on my iPhone and on my Mac (and then synced) and the place I'm on still won't stick on the iPhone.

It's clearly an audiobook in both the iPhone and the Mac, so the usual problem I find on the web doesn't apply.

Sometimes, I see the following screen. It looks like the audiobook is partway listened to, but the forward button doesn't work, and oddly, the beginning and end are both showing 0.

Re: Audiobook Position Lost

Posted: Fri Sep 11, 2015 3:28 pm
by Stephen Hart
I finally gave up on the book shown above. It kept losing its place. And I didn't like the book much anyway. Bah!

(BTW, I'm writing about the latest iBooks.app, where Apple moved all audiobooks.)

But now I'm seeing at least some issues on another audio book. I turns out that both were made with AudioBook Builder from CDs. (I haven't systematically tested downloaded audiobooks.)

In my latest audiobook--which I really do care about listening to*--I'm seeing the back 15 seconds icon and the forward 15 seconds icon not working. I can hear the audio go backward or forward fast, but then it resumes exactly where it was when I started. At least once, the book resumed after a day or so at a place many minutes earlier than where I actually left off.

Now I know that you should be able to swipe the cover image to scrub back and forth, but that doesn't work either.

And, I just tested and found the book starting at the beginning, instead of a couple of hours in.

For me, at least, iBooks in iOS 8 seems to be broken as far as audiobooks go.



* Jade Dragon Mountain, by Elsa Hart

Re: Audiobook Position Lost

Posted: Fri Sep 11, 2015 3:39 pm
by Stephen Hart
So a google search found this discussion:

https://discussions.apple.com/thread/7104268

where several people say they the same problems with AudioBook Builder. I've tried the suggestion to delete the video track using QuickTime 7 Pro. I'll report back.

Here's another forum addressing this issue:
The problem stemmed from Audiobook Builder creating files that are no longer supported by ibooks and iOS. In iTunes I selected the file and clicked the "create sac version" in the popup menu, the file was converted to a compatible format, I lost chapter information but I will take that tradeoff for a file that will actually remember where it was stopped.
I assume the writer means "create aac version."


AudioBook Builder relies on QuickTime, so I hope the publishers fix this issue for El Capitan and going forward. It's a handy app.

Re: Audiobook Position Lost

Posted: Mon Sep 14, 2015 1:43 pm
by Stephen Hart
I've tried the suggestion to delete the video track using QuickTime 7 Pro.
That process works. All the ways of skipping forward and back now work*, and the book kept its place through several stops and starts.

Seems like Audiobook Builder's builders could fix that issue pretty easily.



* In addition to the cool--and safer in a car--method of swiping the cover art, there's another good feature. I don't know if it's new, but it's new to me. If you're skipping by swiping or touching the 15 second button, you can hold it down and the skips will repeat. They get faster, giving you audio feedback as you go.

Re: Audiobook Position Lost

Posted: Tue Sep 15, 2015 8:50 am
by Stephen Hart
I found The Silkworm on a Time Machine backup and removed the video track from that file. It seems to work too.

Re: Audiobook Position Lost

Posted: Fri Sep 18, 2015 11:10 am
by Stephen Hart
And here's another tip I just discovered today. You can set how long skip forward and skip back rewind or fast forward. 15 seconds is the default. Settings > iBooks > Audiobooks

Re: Audiobook Position Lost

Posted: Sun Oct 25, 2015 3:16 pm
by Stephen Hart
One last post:
The original audiobook I was posting about is working perfectly since deleting the video track in QuickTime Player 7 Pro, on both parts.

Audiobook Builder's support forum has posts about this issue and they know about it. A beta is available that may fix this issue. Also, the support site says the programmers are working on Audiobook Builder 2.0.