Mail deletes signature?

Discussion of issues related to OSX 10.9 (Mavericks) and all earlier versions of OS X.
Post Reply
User avatar
Stephen Hart
Forum Member - Level 5
Forum Member - Level 5
Posts: 3111
Joined: Thu Apr 07, 2011 10:09 am

Mail deletes signature?

Post by Stephen Hart » Fri Jan 11, 2013 4:28 pm

Here's a poser:

In Aperture, I have Mail set up for sharing one or more photos by e-mail. And I have the option to include metadata checked. Here's what happens:

I select a photo, click the e-mail button (or any other of the methods of e-mailing direct from Aperture).
Mail opens with a new message including the photo but no metadata. The new message also includes my default signature.
Then the Mail window flashes and the signature is deleted.

I just checked this in iPhoto, which I no longer use, and got similar results. From iPhoto, the Mail message includes the image title, but the window still flashes and the signature is deleted.

I can't find anything in Mail's preferences or Aperture's that seems in any way related. And I've googled till my googler is sore, but found not a hint. It's as if there's a preference for no signature when e-mailing from another app.

By the way, an alternative method of e-mailing one or more photos from Aperture--selecting and dragging to the Mail icon in the Dock--does not erase the signature.
"Design is not just what it looks like and feels like. Design is how it works."
Steve Jobs

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests