Page 1 of 1

Contacts Not Syncing Via iCloud

Posted: Mon Dec 17, 2012 11:14 pm
by Richard Serkes
The contacts I add on my iMac are not getting to my iPad via iCloud. I have CONTACTS checked off on my iPad and iMac to be synced but it just isn't happening.

Any ideas?

I'm using 10.8.x on my iMac and iOS 6.x on the iPad.

Re: Contacts Not Syncing Via iCloud

Posted: Tue Dec 18, 2012 8:06 am
by Stephen Hart
We just faced this issue, and found a solution. It's worth a look in your case.

In Contacts, like in Mail, you can have contacts On My Mac or in iCloud. In Contacts > Preferences > General, make sure the Default Account is iCloud.
On the Mac we had trouble with, we had to copy all the contacts from On My Mac to the iCloud account. I did them one alphabet letter at a time, just dragging and dropping. I ended up with a couple of duplicates only, and resolved those by hand.

On my iMac, which has always synced properly, only iCloud is shown in the Accounts section of the sidebar.

See screen shots.

Re: Contacts Not Syncing Via iCloud

Posted: Tue Dec 18, 2012 9:58 am
by Richard Serkes
BINGO!

Thanks for the hint. I never would have found that preference. I've set iCloud as my default, moved the contacts still in the On My Mac area to iCloud and then deleted every contact in the On My Mac area. All is good.

Re: Contacts Not Syncing Via iCloud

Posted: Tue Dec 18, 2012 10:29 am
by Stephen Hart
I was completely unaware of those settings until last week. And we only found out about it because my wife used her Mac to add a contact. Previously we'd both used my Mac.

Re: Contacts Not Syncing Via iCloud

Posted: Sun Jan 04, 2015 11:02 am
by blackieb
HI all! This is getting at my problem, but I am still struggling getting my contacts for iCloud and On My Mac to sort out - here's my issue:

I USED to have two "accounts" - one On My Mac and one iCloud, since I added an iCloud account once that became available, so that I could synch across platforms. So everything was working fine - my contacts were available on my iphone and iPad. But, on my laptop, I still had two sections - my iCloud Contacts and my On My Mac Contacts. Unfortunately, the On My Mac contacts folders were named the same as my iCloud folders (since they were essentially a copy from when I added iCloud, but they weren't being updated). I was JUST thinking that I should delete them, when, for some unknown reason, the On My Mac account is no longer parsed out - so now, all of a sudden, I have TWO folders of each group - each with identical names, all in one list in the sidebar, not sorted by account!!! So I don't know which is the iCloud folder/Group or which is the old On My Mac group! Very frustrating! And I don't know why this changed. Some update? (I'm using OS 10.9.5)
So, when I go to preferences, accounts in contacts, it shows iCloud and On My Mac (local) but there is no Account information. And when I go to Preferences, General, there is no option to have a default account (as there used to be) so it seems like the Local Account went away, but not completely.

Should I try to re-add the On My Mac account somehow so that I can sort out the groups? Or is there an easy way to tell which folder is which so I don't delete the most updated group? And actually, how DO you get rid of a group anyway? I don't seem to be able to delete a group from my sidebar.

Any thoughts or help would be appreciated! Thanks! I maintain some large email distribution groups for the Port Angeles Christmas Count so I really don't want to start over, if possible! Thanks!

Re: Contacts Not Syncing Via iCloud

Posted: Sun Jan 04, 2015 3:33 pm
by Stephen Hart
I see the same options you describe in Yosemite. But as I don't use groups, I can't help with that.

Re: Contacts Not Syncing Via iCloud

Posted: Sun Jan 04, 2015 11:34 pm
by Ray Bentsen
Make sure you have Contacts syncing turned off in iTunes.
blackieb wrote: And actually, how DO you get rid of a group anyway? I don't seem to be able to delete a group from my sidebar.
Delete a group from the Edit menu, as in this screenshot (from OS X 10.10)

Re: Contacts Not Syncing Via iCloud

Posted: Mon Jan 05, 2015 6:39 am
by Stephen Hart
Make sure you have Contacts syncing turned off in iTunes.
Good point, Ray.
If you want to sync via iCloud, check to be sure you're not also trying to sync in iTunes.

Select your iPhone or iPad in Devices.
In the sidebar, a list of settings appears, with Summary at the top and Info at the bottom. Select info.
Everything should be unchecked.

Re: Contacts Not Syncing Via iCloud

Posted: Sat Oct 15, 2016 1:08 pm
by Stephen Hart
We just ran into this issue again today (in iOS 10). I'm not sure how long it's been going on, but my wife's contacts did not show a contact newly added on one of our Macs; her list wasn't syncing.

We have Family Sharing, but that doesn't sync contacts.

The solution was to go to Settings > Contacts and add a new account. The one we added was our main Apple ID. Then we turned Contacts on in that account and off in her own Apple ID. Problem solved.